Android 4.0 and above

Posted 4 years ago by admin

Currently the app only supports Android 4.0 and above. Please update your software.

Bookmark the permalink.